


Table of Contents

Foreword 0

Part I Introduction 2

................................................................................................................................... 21 Welcome 

................................................................................................................................... 22 Getting Familiar With WakeMeUp! 

Part II Functions 3

................................................................................................................................... 31 Overview 

................................................................................................................................... 42 Choosing a Skin 

................................................................................................................................... 43 Selecting a Language 

................................................................................................................................... 54 Immediate Alarm Indicator 

................................................................................................................................... 55 WakeMeUp! State 

................................................................................................................................... 66 New Alarm 

................................................................................................................................... 87 Editing an Alarm 

................................................................................................................................... 98 Deleting an Alarm 

................................................................................................................................... 99 TimeSlider 

................................................................................................................................... 910 Activating/Deactivating an Alarm 

................................................................................................................................... 911 Computer StandBy 

................................................................................................................................... 912 Preferences 

................................................................................................................................... 1113 Alarm Notification 

Part III Common Tasks 11

................................................................................................................................... 111 Creating an Everyday Alarm 

................................................................................................................................... 122 Mum's Birthday Notification 

Part IV Glossary 13

................................................................................................................................... 131 ACPI 

................................................................................................................................... 142 S1 and S3 Sleep Modes 

................................................................................................................................... 143 Sleep Mode 

................................................................................................................................... 144 NT System Service 

Index 0

WakeMeUp! Help SystemI

© 2003-2004 Highspheres.com



Introduction 2

© 2003-2004 Highspheres.com

1 Introduction

1.1 Welcome

Congratulations!

You have just installed the application that can turn your
computer into an excellent alarm clock with almost unlimited
functionality.

WakeMeUp! can:

· Make your computer enter sleep mode (S3 or S1) and resume from it
· Play mp3, wma or wav. m3u playlists are also supported
· Play chimes at the beginning of every hour your PC is turned on
· Execute any command line (start a program, run a file)
· Work with no user passwords required
· Handle alarms from multiple users of your PC
· Work even when no user is logged on
· And much more...

WakeMeUp! is able to do this all.

Dear User, I hope you will be pleasantly surprised with this software.

1.2 Getting Familiar With WakeMeUp!

WakeMeUp! is not a single .exe software. It is a rather sophisticated complex that consists of the
following modules:

· WakeMeUp.exe is the main application of WakeMeUp! software. It provides an interface for
manipulations with your alarms. It is the only program you need to run to completely configure
WakeMeUp! system.

· WMUSvc.exe is a system service. It starts along with other windows services, such as network
support or WinXP skin support. This program doesn't require a user to be logged on. Actually, this
program fires all alarms of WakeMeUp! system. It has no interface and can be completely
configured by means of WakeMeUp.exe

· Informer.exe is a program that notifies you of your alarms. It can play a sound (mp3,wma or wav) or
display a message.

· WMUTray.exe is a small program that sits in tray and informs you about WakeMeUp! status.

The following scheme illustrates how the system works.
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Let's briefly describe the drawing above. Every user of your PC for whom WakeMeUp! is installed is
allowed to create and manage his own alarms. It's very important to point out that a user can manage
only his own alarms. In spite of it any user can see the immediate alarm, no matter whose it is.
Another important point is that WakeMeUp.exe is responsible only for managing user alarms. It
doesn't fire an alarm itself. Therefore, you need to run it only when you want to configure or
reconfigure your alarm list. And, by the way, it is the only program you will ever need to run!
WakeMeUp! system service (WMUSvc.exe) is always running. It doesn't consume much resources
and therefore you can forget about it. Actually, it is the main component of WakeMeUp! software. It is
responsible for managing alarms from multiple users and starting alarm notifier (Informer.exe) when
required.

2 Functions

2.1 Overview

All functions provided by WakeMeUp! alarm management utility are described in this chapter.
The most frequently used functions can be called in two or three different ways: from toolbar,main
menu or context menu. Let's have a look at them.

WakeMeUp! Toolbar
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Main menu

Context menu

2.2 Choosing a Skin

A skin is a combination of visual elements of a program.

WakeMeUp! has the following built-in skins:

· MacOS
· WinXP
· Deep Blue
· Protein
· Blue Glass

To change WakeMeUp! skin go to main menu and choose View -> Skins, then click on a skin name.

WakeMeUp! supports additional skins you can download from our server. There are 5 additional
skins included in installation package. Click View -> Skins -> More... to get the list of available
additional skins. Choose View -> Skins -> More...-> Get More Skins to open WakeMeUp! skin
explorer that will help you to preview, download and install additional skins. You need to have an
internet connection established to work with Skin Explorer as it downloads skin list, skin screenshots
and skins themselves from our server.

2.3 Selecting a Language

WakeMeUp! interface can be translated into a number of languages. You can choose the one you
prefer. When WakeMeUp! is started first time, it automatically chooses interface language. This
choise is made on the basis of OS settings.

To change WakeMeUp! interface language do the following: go to main menu, then select View ->
Languages, then select the language you prefer.
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The author will be very grateful for translating WakeMeUp! into your native language. I will be really
glad to present you a special build and 3 license keys of WakeMeUp! Your name will be written in
About... window in all further builds that will include your translation.

2.4 Immediate Alarm Indicator

Immediate alarm indicator informs user of the immediate alarm that will be fired by WakeMeUp!, no
matter whose alarm it is.
Usually its panel looks like the picture below. There's a Chime State Indicator in the top-right corner
of the panel. The chime is on when it is coloured and off when it's gray. Click it to toggle Chime
On/Off.

2.5 WakeMeUp! State

A standalone WMUTray.exe application is responsible for displaying WakeMeUp! State in windows
system tray. It is displayed as a small bell icon you can click on to open its window. Double-click it to
run WakeMeUp! Configuration Utility.
This application is launched automatically at Windows startup. You can enable/disable autostart
feature by checking/unchecking the "AutoRun WakeMeUp! State (a small bell icon in system tray)"
checkbox in Preferences.. .-> System Tray.
When immediate alarm changes a balloon hint is displayed. This function can also be disabled on
System Tray tab of the Preferences window.
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2.6 New Alarm

In order to create a new alarm you should:

1. Press New Alarm button on the toolbar or choose New Alarm from context menu or go to main
menu and select Edit -> New   Alarm

2. In the alarm setup window please fill in all properties you would like to set.
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Comment/Alarm Title is a short text string that briefly describes the alarm.

Periodicity indicates how often you want your alarm to fire. It can be set to one of the following
values:

Once The alarm will fire only at specified alarm date/time and WakeMeUp! will switch
your computer to standby mode only at the date/time specified in Stand By at
field (if checked).

Every Day WakeMeUp! will fire this alarm every day starting from the day specified.

At workdays The alarm will fire only on Monday,Tuesday,Wednesday,Thursday and Friday.

At weekend The alarm will fire only on Saturday and Sunday.

Every week Let's suppose that we set the alarm time to 20:35 on 9 Jan 2004. It is Friday.
So, if the periodicity of this alarm is set to Every week, then it will be fired every
Friday since 9 Jan 2004.
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Every month Let's suppose again that we set the alarm time to 20:35 on 9 Jan 2004. So, if
the periodicity of this alarm is set to Every month, then it will be fired at 20:35 on
the 9th day of every month since January.

Every year The alarm will fire every year on the specified date at the specified time. For
example, Mum's birthday.

Selected days The alarm will fire only on the days you selected in CheckCalendar.

Alarm Time is the date/time when you want the alarm to be fired and your computer to wake up (if it
is in standby
mode)

Stand By is the date/time associated with current alarm  when you want your computer to switch to
StandBy mode.

Action indicates the way you want WakeMeUp! to notify you of the alarm. There are four possible
choices:

· Show message
· Play specified sound (mp3/wma/wav/m3u)
· Execute command line (run a program or open a file)
· Repeating PC Speaker Beeps.

2.7 Editing an Alarm

Editing an existing alarm is very close to creating a new alarm.

1. Select the alarm you would like to edit in alarm list
2. Click Edit on toolbar
3. The Alarm Setup window will appear. For detailed description of its interface please read
New Alarm topic

Use TimeSlider control to edit selected alarm wake up time.
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2.8 Deleting an Alarm

To delete the alarm you should:
1. Select an alarm
2. Press Delete button on the toolbar

It is not always the best way out to delete an alarm you think you don't need anymore. You may
simply deactivate it by removing the corresponding check mark in front of it in alarm list. In this case
you will be able to re-use it in future.

2.9 TimeSlider

TimeSlider is a unique WakeMeUp! feature. It was designed to help you to set time of your alarms
much faster and easier than ever!
TimeSlider's pane consists of a trackbar, a timescale and buttons. You can adjust the alarm time
simply by moving trackbar slider. The time that corresponds to the slider position is shown above the
trackbar. The scale will help you to find the time you need.
Select an alarm, then click Ctrl-T or press Change Alarm Time in its context menu to access this
control.

2.10 Activating/Deactivating an Alarm

An ability to activate/deactivate an alarm is a very useful feature of WakeMeUp!
To activate an alarm you should select the alarm you want to activate in alarm list, then click on its
checkbox. Alarm is activated when the checkbox is checked.
Click column header to activate/deactivate all alarms at once. You can use the <SPACE> button
instead of clicking a checkbox.
An alarm can be created deactivated, although it is active by default.

2.11 Computer StandBy

You may switch your PC to standby mode directly from WakeMeUp! To do so just click StandBy
button on the toolbar.
A forced switching to StandBy mode can be enabled on General tab of Preferences window.

2.12 Preferences

Click Preferences button on the toolbar to open the Preferences window.
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General

· Forced StandBy mode. WakeMeUp! will bypass all system warnings and pauses when going to
StandBy.

· Show tip of the day at startup. A Tip Of The Day window with a new tip will be displayed every
time WakeMeUp! is started.

Sound

· Set mixer volume to max when playing alarm sound. This may help you to hear an alarm.
· Beep using PC Speaker when alarm notification is over. A series of beeps will be made through

PC Speaker when the sound file you selected for alarm notification has been played. If there's
an m3u playlist instead of sound file, then WakeMeUp! will make short beeps after every
playlist position and start its long series of beeps when the playlist is over. It is recommended
that you leave this function enabled.

· Use fade-in when playing alarm sound. WakeMeUp! will gently increment the sound volume
when playing alarm sound. Use the Fade-in length slider to define how gentle the fade-in
should be.

System Tray

· AutoRun WakeMeUp! State (a bell icon in system tray). When this option is checked a bell icon
is displayed in system tray automatically.

· Show balloon hints when immediate alarm changes. A balloon hint with new immediate alarm
properties is displayed every time a new immediate alarm is set by WakeMeUp! System
Service.
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2.13 Alarm Notification

Alarm notification is handled by means of a special program (Informer.exe)
When an alarm is fired, WakeMeUp! system service tells Informer.exe to notify you of your alarm.
Depending on type of alarm action Informer's window may look like this (displaying a message)

or like this (playing a sound)

You can postpone the alarm at any moment by pressing a Snooze button. Each time you press any of
these buttons the time to sleep is increased by 5 or 10 minutes. In this case Informer's window will
look like this

3 Common Tasks

3.1 Creating an Everyday Alarm

For example, you prefer to wake up every day at 8:00. Click New Alarm button on the toolbar, then fill
in the windows fields in this way
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Click OK and voila!

3.2 Mum's Birthday Notification

For example, your mum's birthday is on 26th of October. You just need WakeMeUp! to remind you
about it, not to wake you up. So, click New Alarm button on the toolbar, then fill in fileds of the
following window this way
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Click OK and voila!

4 Glossary

4.1 ACPI

Advanced Configuration and Power Interface (ACPI) is an open industry specification that defines a
flexible and extensible hardware interface for the system board. Software designers use this
specification to integrate power management features throughout a computer system, including
hardware, the operating system, and application software. This integration enables operating system
to determine which applications are active and handle all of the power management resources for
computer subsystems and peripherals.
If you are not sure whether your computer is ACPI-compliant, check your computer's documentation.
ACPI is not always properly installed during the installation of Windows OS.
There's a simple test to check whether it is properly installed. Click Start->Turn Off Computer. If
StandBy is available in this menu, then windows is able to work with ACPI. If StandBy button is grey
and you are sure your PC supports ACPI (almost all computers manufactured since 2000 do so), you
should reinstall windows. An important tip: before reinstalling go to your BIOS setup -> Power
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management and set there ACPI to enabled and Suspend mode to S1 (important!). After installation
completes, you should set Suspend mode to S3.

4.2 S1 and S3 Sleep Modes

If your PC supports ACPI (Advanced Configuration and Power Interface) there are two
sleep (standby) modes - S1 and S3.
When your computer is in S1 mode, its noise is very low, but still it is. This noise comes from power
supply fan.
In S3 mode there's no noise from your PC. The only device that remains powered is RAM (Random
Access Memory), which doesn't consume much power.

4.3 Sleep Mode

Sleep mode (or StandBy) is a state of your PC when it makes no noise, because neither processor
nor hard drives are working. But  in spite of it it can be woken up in a couple of seconds simply by
pressing a key on keyboard or power button on PC case. To support noiseless sleep mode your
computer's BIOS must be properly configured. For advanced information on this topic read about
S1 and S3 Sleep Modes and ACPI

4.4 NT System Service

NT System Service is special program that is started automatically at windows startup, therefore there
is no need for user to run it. Usually it is responsible for some service functions, such as automatic
disk defragmentation or database management. System service has no interface and can be run only
under Windows NT/Windows 2000/Windows XP/Windows Server 2003/Windows Longhorn. Usually
only administrator is allowed to install a service.
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